EDGE Community
FAQ  FAQ   Search  Search   Memberlist  Memberlist   Usergroups  EDGE Home
Register  ::  Log in Log in to check your private messages


Post new topic  Reply to topic
 3d « View previous topic :: View next topic » 
Author Message
DooMXTerminator
PostPosted: Tue 22 May 2012 3:48 am    Post subject: 3d Reply with quote



Joined: 22 May 2012
Posts: 1

iv heard on many different forums that edge used to have anaglyph 3d is this true?
Back to top
View user's profile Send private message Send e-mail
andrewj
PostPosted: Tue 22 May 2012 3:05 pm    Post subject: Reply with quote



Joined: 05 May 2007
Posts: 698
Location: Tasmania

Yes I think it did, but it was a very long time ago (the effect was done in software renderer, but the sw renderer was replaced by OpenGL renderer around 1.26 or 1.27). I don't know which version of EDGE had this feature (if any), perhaps 1.23 or 1.24

Here is the comment from Erik Sandberg's log:

Quote:
1999/07/25

Fixed some console bugs.

Added a cyan-red glasses 3D effect.

Changed the meaning of SCREENDEPTH from width*bpp to address difference
between two vertically adjacent pixels. Then increased SCREENDEPTH to always
be divisible by 32 but never by 64. This Speeds up the rendering of columns
by more than 150% in some cases, it works around a limitation of the cache.

Screen wiping has been temporarily removed, since it didn't like the
SCREENDEPTH fix, plus it needs cleanup anyways.
Back to top
View user's profile Send private message
zZaRDoZz
PostPosted: Sat 26 May 2012 3:35 pm    Post subject: Reply with quote



Joined: 10 Aug 2009
Posts: 132

Sorry if this kidnaps the thread, but I may have just got the 3d view driver IZ3D working ing edge thanks to titaniumgl. I don't have any 3d glasses at all so there's no way for me to be certain. All I can say is I'm getting 2 separate colors displaying when the driver is on, not to mention the test messages telling the user how to test the driver when I run EDGE. Admittedly, having to run one wrapper on top of another has to be the worst way to do things, Vavoom has a dedicated D3D driver if you wish to test that port.

Here's the links for both:

http://titaniumgl.tk/

http://www.iz3d.com/driver

I don't know if all settings will work. I'll research it more later.
Back to top
View user's profile Send private message
zZaRDoZz
PostPosted: Sun 27 May 2012 7:54 pm    Post subject: Reply with quote



Joined: 10 Aug 2009
Posts: 132

Okay, I may not be getting stereo imagery in EDGE like I thought I was. It renders best in the setting called anaglyph, with blue/yellow offering the only split image that I can see. I don't see that split in the actual rendering though, just the test pic. I tried IZ3D with vavoom and that does provide a discernible split image when rendering in D3D mode.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic  Reply to topic Page 1 of 1

Jump to:  



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum